Emoji PR comments not triggering approval
Incident Report for PullApprove
Resolved
If you use emojis in your regex patterns, we'll now automatically check for their Unicode equivalents. Let us know if you experience any issues with approving by comment.
Posted about 2 years ago. Apr 18, 2016 - 20:45 CDT
Identified
GitHub has recently changed the way that emojis are used when using their autocomplete dropdown. If you use the autocomplete, it will use the Unicode emoji instead of the :alias:. This throws off the regex matching in PullApprove (or anything else for that matter). We're working to get a solution in place so that you don't have to add Unicode patterns to your .pullapprove.yml.
Posted about 2 years ago. Apr 18, 2016 - 14:35 CDT